Diagnostics is Experiencing Issues
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 08:26 UTC
Investigating
We are currently investigating this issue.
Posted Mar 23, 2021 - 22:45 UTC
This incident affected: Diagnostics.