Account Management Is Experiencing Issues
Incident Report for App Center
Resolved
The issues with Account Management have been resolved and all operations are back to normal now. Thanks for bearing with us!
Posted 22 days ago. Aug 30, 2019 - 20:04 UTC
Investigating
App Center is experiencing issues with the Account Management service. We apologize for the inconvenience while we work to resolve this issue.
Posted 22 days ago. Aug 30, 2019 - 17:00 UTC
This incident affected: Account Management.