Release Upload is Experiencing Delays

Incident Report for App Center

Resolved

This incident has been resolved and all systems are fully operational. We apologize for the inconvenience once again.
Posted Oct 27, 2022 - 18:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 27, 2022 - 15:12 UTC

Identified

App Center is experiencing a temporary issue processing release upload requests. As a consequence, users may experience delays or failures.
We apologize for the inconvenience while we work to resolve this issue.
Posted Oct 27, 2022 - 11:16 UTC
This incident affected: Distribute.