Release Upload is Experiencing Delays
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 17:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2022 - 16:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 25, 2022 - 15:44 UTC
Investigating
App Center is experiencing a temporary issue processing release upload requests. As a consequence, users may experience delays or failures.
We apologize for the inconvenience while we work to resolve this issue.
Posted Nov 25, 2022 - 15:39 UTC
This incident affected: Distribute.