App Center is experiencing issues

Incident Report for App Center

Resolved

This incident has been resolved.
Posted Aug 10, 2024 - 20:36 UTC

Investigating

App Center is experiencing issues with the diagnostics. We apologize for the inconvenience while we work to resolve this issue.
Posted Aug 10, 2024 - 19:34 UTC
This incident affected: Diagnostics.