App Center is experiencing issues
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Jun 19, 2024 - 06:05 UTC
Investigating
App Center is experiencing issues with the Analytics/Diagnostics. We apologize for the inconvenience while we work to resolve this issue.
Posted Jun 16, 2024 - 21:44 UTC
This incident affected: Diagnostics and Analytics.