Distribute is Experiencing Issues
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Dec 17, 2021 - 05:50 UTC
Investigating
App Center is experiencing a temporary delay processing Distribution to Store. We apologize for the inconvenience while we work to resolve this issue.
Posted Dec 16, 2021 - 16:59 UTC
This incident affected: Distribute.