Issue Discovered
Incident Report for App Center
Resolved
The issue with delayed processing with App Center Distribute has been resolved and we continue to monitor. Thanks for bearing with us!
Posted 5 months ago. Dec 24, 2018 - 07:42 UTC
Investigating
App Center is experiencing a temporary delay processing Distribution Service. We are sorry for the inconvenience and are investigating.
Posted 5 months ago. Dec 24, 2018 - 07:23 UTC
This incident affected: Distribute.