Account Management Service is Experiencing Issues
Incident Report for App Center
Resolved
The issue with App Center Accounts has been resolved and all operations are back to normal now. Thanks for bearing with us!
Posted about 2 months ago. Jul 03, 2019 - 00:33 UTC
Investigating
App Center is experiencing issues with the Account Management service. We apologize for the inconvenience while we work to resolve this issue.
Posted about 2 months ago. Jul 02, 2019 - 19:58 UTC
This incident affected: Account Management.