Delay in e-mails sent to new testers
Incident Report for App Center
Resolved
Testers are receiving e-mails at a normal pace again.
Posted 17 days ago. Nov 26, 2018 - 15:54 UTC
Identified
Testers are receiving e-mails with a delay due to an internal problem. We have identified the issue and are working on a fix.
Posted 17 days ago. Nov 26, 2018 - 15:18 UTC
This incident affected: Distribute.