AppCenter is having issues with sending emails
Incident Report for App Center
Resolved
This incident has been resolved by our email delivery provider.
Posted Mar 15, 2022 - 08:46 UTC
Update
We are continuing to investigate this issue.
Posted Mar 15, 2022 - 08:45 UTC
Update
We are working with email delivery provider on resolving the issue.
Posted Mar 14, 2022 - 18:09 UTC
Investigating
App Center is experiencing issues with emails. We apologize for the inconvenience while we work to resolve this.
Posted Mar 14, 2022 - 17:44 UTC