Test Cloud experiencing issues
Incident Report for App Center
Resolved
This incident has been resolved.
Posted May 08, 2023 - 15:12 UTC
Identified
Test Cloud experiencing issues, you may experience issues with launching tests.
Posted May 08, 2023 - 14:31 UTC
This incident affected: Test.