Account Management Is Experiencing Issues
Incident Report for App Center
Resolved
The issue with App Center Accounts has been resolved and all operations are back to normal now. Thanks for bearing with us!
Posted 3 months ago. Jul 10, 2019 - 22:23 UTC
Investigating
App Center is currently experiencing intermittent issues with the Accounts Management service. We apologize for the inconvenience while we work to resolve this issue.
Posted 3 months ago. Jul 10, 2019 - 17:37 UTC
This incident affected: Account Management.