Inability to start a Test run.
Incident Report for App Center
Resolved
Issue resolved, Test service is operating as expected now.
Posted 27 days ago. Nov 16, 2018 - 20:46 UTC
Investigating
We are investigating an issue which impacts ability to start a Test run.
Posted 27 days ago. Nov 16, 2018 - 17:54 UTC
This incident affected: Test.