Distribute Is Experiencing Issues
Incident Report for App Center
Resolved
The issues with App Center Distribute have been resolved and all operations are back to normal now. Thanks for bearing with us!
Posted 26 days ago. Apr 29, 2019 - 12:45 UTC
Investigating
App Center is currently experiencing intermittent issues with the Distribute service. We apologize for the inconvenience while we work to resolve this issue.
Posted 26 days ago. Apr 29, 2019 - 11:01 UTC
This incident affected: Distribute.