Issue Discovered
Incident Report for App Center
Resolved
The issues with downloading apps from install.appcenter.ms has been resolved. Thanks for bearing with us!
Posted 11 days ago. Jan 10, 2019 - 21:59 UTC
Investigating
App Center users are experiencing issues downloading some apps from install.appcenter.ms. We are sorry for the inconvenience.
Posted 11 days ago. Jan 10, 2019 - 21:46 UTC