Issue Discovered
Incident Report for App Center
Resolved
The issues with App Center Distribute have been resolved and all operations are back to normal now. Thanks for bearing with us!
Posted 2 months ago. Mar 14, 2019 - 04:57 UTC
Investigating
We are currently experiencing issues with distributing to Google Play Store. We apologize for the inconvenience while we work to resolve this issue.
Posted 2 months ago. Mar 13, 2019 - 04:12 UTC
This incident affected: Distribute.