Distribute High Load
Incident Report for App Center
Resolved
Issue was resolved
Posted Dec 27, 2021 - 10:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 23, 2021 - 14:35 UTC
Investigating
Due to high load to our servers, customers can experience "Too Many Request" response when creating a new release.
Posted Dec 20, 2021 - 15:58 UTC
This incident affected: Distribute.