Email notifications delayed
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 00:45 UTC
Investigating
We are investigating an issue with email notifications' delayed delivery.
Posted Dec 07, 2022 - 12:03 UTC
This incident affected: Distribute.