Execution of tests on the Test Cloud is experiencing the issue
Incident Report for App Center
Resolved
This incident has been resolved.
Posted May 02, 2021 - 00:20 UTC
Update
ETA for mitigation ~6 hours.
Posted May 01, 2021 - 16:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2021 - 14:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2021 - 13:01 UTC
Investigating
App Center is experiencing issues. We apologize for the inconvenience while we work to resolve this issue.

Currently impact is isolated to the Test Cloud part only.
Posted May 01, 2021 - 10:54 UTC
This incident affected: Test.