Distribute is Experiencing Issues
Incident Report for App Center
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 21:49 UTC
Update
We are continuing to investigate this issue.
Posted Mar 18, 2021 - 21:45 UTC
Investigating
App Center is experiencing a temporary delay processing Distribution. We apologize for the inconvenience while we work to resolve this issue.
Posted Mar 18, 2021 - 11:13 UTC
This incident affected: Distribute.