Resolved issue with creating a new release
Incident Report for App Center
Resolved
Period of Customer Impact: 6/13 10:08am PT to 6/13 10:57am PT
Users may have seen a blank page when distributing new releases. We apologize for the inconvenience, this issue has now been resolved
Posted 2 months ago. Jun 14, 2019 - 21:07 UTC
This incident affected: Distribute.