Issue Discovered
Incident Report for App Center
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 31, 2018 - 14:25 UTC
Investigating
App Center is experiencing a temporary delay processing
Billing requests. As a consequence, changing billing plans might not work. We
are sorry for the inconvenience.
Posted 14 days ago. Oct 31, 2018 - 14:08 UTC
This incident affected: Account Management.